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1.  Introduction
Thank you for buying SwiftCad, the professional 2D Computer Aided 
Design (CAD) package for Windows. SwiftCad is intended for the first-
time or casual user, as well as the design professional. It is faithful to all 
Windows user interface conventions and provides Clipboard support.

SwiftCad's editing commands are especially flexible, and it exchanges 
drawings with virtually any other CAD or CAM package, or Windows 
application, with no conversion necessary.

In this manual you will find:
• Instructions for installing SwiftCad
• A brief tutorial
• The layout of the menu structure and its functions
• A brief guide to keyboard accelerators
• A list of the Program disk's contents

In addition to the descriptions of the commands included in this manual, 



there is a comprehensive on-line help system.
2.  Installation Instructions
•  Put the Installation disk in drive A or B.
•  From the Program Manager, open the File menu and choose the Run 

command.  Type the letter of the drive that the disk is in followed by 
“:INSTALL”.  For example,  “A:INSTALL” or “B:INSTALL”.

•  Click on the OK button.  Continue to follow the instructions on screen 
until the Install program finishes.

3.  Tutorial

To run SwiftCad 
Double-click on its icon and wait for a few seconds as the program is 
loaded. At this stage, on-line help will be available, which has much of 
the same information included in this manual.  You may also follow the 
tutorial below, which explains the basic drawing and editing commands.

To begin a new drawing
When SwiftCad loads, it creates a new, untitled drawing which you can 
name upon saving.  It helps if you maximize the drawing, so you can see 
all the menus clearly. See Appendix A for a brief description of SwiftCad's
menu commands.
To draw a rectangle
To begin with, you are going to draw a rectangle with the coordinates 
(15,25) and (65,65) using the Draw menu. Then you will delete the 
rectangle and draw it again using the Toolbox and grid.

Using the Draw menu
• Choose Rectangle from the Draw menu. 
• Enter the lower left x-ordinate (15) at the insertion point. 
• Position the cursor in the lower box (using Tab or the mouse) 
and enter the lower-left y-ordinate (25).
• Click OK to specify the upper right point (65, 65) in the same 
way.

To delete the rectangle
The rectangle will be selected by default.  Deselect it by clicking 
anywhere outside the rectangle.  Select it by clicking inside the rectangle.
Delete the rectangle using Delete or Cut from the Edit menu or the 
Delete key.  Now draw the rectangle again, using the Toolbox and Grid. 

Defining a Grid
• Choose Grid from the Settings menu. 
• Type 5 for the X- and Y-spacing. This means your grid will have a



mesh measuring 5 units on the X and Y axes.
• Set Show and Snap (so the boxes are checked). This means the
grid appears shown on your drawing, and all entities you draw will 
snap to the nearest grid point.
• Click on OK to draw the grid.

Using the Toolbox
• The Toolbox is displayed by default.  It can be turned on and off 
from the "View" window.
• Move the Tools window to a convenient part of the screen by 
clicking on its title bar and dragging it to a new position. 
• Click on the Rectangle icon. Note that by double-clicking on the 

rectangle button, you can make it the default button.  Ordinarily, 
the cursor button is the default.
• Position the cursor in the drawing near the 15,25 grid point.
• Holding the mouse button down, drag and release when the 
lower right co-ordinate is near the 65,65 grid point.  Because you 
set Snap, the rectangle snaps to exactly the points you want.
• Notice the handles at each corner. This means it is selected and 

can be moved, sized, etc. 
• Click anywhere to deselect it.
Now you're drawing!
Experiment with drawing circles, arcs and lines, using the Toolbox and 
the Draw menu. To draw a circle, you need to specify the center and 
radius. For an arc, you need the start and end angles, radius and center. 
Practice selecting objects, then moving, deleting, mirroring or rotating 
them. If you get stuck, on-line Help is only a menu away!
4.  Menu Commands

File
The File Menu allows you to create a new drawing; open an existing 
drawing; save and rename drawings; select a printer and print your 
drawing; exit SwiftCad. You can work with as many drawings and entities
(objects within a CAD file) as the memory installed in your computer will 
allow.

Opening a new file
To open a new file, choose "New" from the File menu, or "Control+N" 
from the keyboard. A new window appears. This window will be untitled 
until you save it, using the "Save As..." option in the File menu.

Opening an existing file
To open an existing file, choose "Open" from the File menu, or 
"Control+O" from the keyboard. A dialogue box appears, listing the files 



in the specified directory.

By default, the program looks for files in it's own format, those that end 
with the extension ".ccf."  You can also look for CAD interchange format 
files, compressed or uncompressed, those files with the extension ".dxf" 
or ".dx_," respectively.  The "Open" command can also be used to 
access the line fonts provided with SwiftCad, which have the extension 
".fnt."  Finally, the "All Files" option will show every file in the SwiftCad 
directory.  Each of these functions is controlled by the pull-down menu in 
the lower left hand corner of the "Open" box.

If the filename is in the list, double click on the name, or click on it and on
OK to open the file. Otherwise, type the name in the box and click on OK.

In addition to using the File menu or keyboard, there is another way of 
opening an existing drawing: by dragging it from the File Manager and 
dropping it onto a running copy of Smartdraw.  ("Drag and drop.")
A drawing may be opened for reading only by checking the "Read Only" 
box in the File Open dialog.  A read only drawing is indicated by a status 
box at the bottom of the screen.  It remains read only until Saved As a 
new file.  (This status box also displays whether a file has been
modified.)

Saving a file
Save a file by choosing "Save" from the File menu, or "Control+S" from 
the keyboard. When you save a new, untitled file, the "Save As..." 
dialogue box appears, allowing you to name the file.  By default, 
SwiftCad will save files with the ".ccd" extension, unless you specify 
another.

Save a new file by choosing "Save As" from the File menu. Type the 
filename in the "Save As..." dialogue box and click on OK to save. The 
new filename replaces "Untitled" in the title bar. You can now save the file
as frequently as you wish.

If you exit before saving a new file, a dialog box appears with the 
question "Save changes to Untitled?"  If you click on Yes, the Save As 
dialog box appears. Alternatively, click on Cancel, and choose "Save As" 
from the File menu.

Printing
To print a drawing, first choose "Printer setup" from the File menu. A 
dialog box appears, allowing you to choose the paper source and size, 
orientation, etc. For help on the printer setup, click the Help button.  Click
on OK to accept the printer currently selected.



To print the file, choose "Print" from the File menu, or "Control+P" from 
the keyboard. To see page breaks before printing, choose "Page breaks" 
from the Settings menu.

Exiting SwiftCad
To exit SwiftCad, choose "Exit" from the File Menu. If you exit without first
saving any changes, you will be prompted to save changes to every 
open and modified drawing.

Edit
The Edit Menu allows you to undo the previous operation, to use the 
Windows Clipboard for cutting, copying and pasting, to delete, duplicate 
and select all entities.

Undoing
To undo the previous cut or delete action, choose "Undo" from the Edit 
menu, or "Control+Z" from the keyboard. You cannot undo an action 
once you have carried out another.

Cutting
To cut an object, select it, then choose "Cut" from the Edit Menu, or 
"Control+X".  The selected object is copied to the Windows clipboard, 
from which you may paste it elsewhere, or retrieve it with the "Undo" 
command.

Copying
To copy an object, select it, then choose "Copy" from the Edit menu or 
"Control+C" from the keyboard.  A copy of the selected object is placed 
on the Windows clipboard, the original is left where it came from and the 
copy may be pasted anywhere within the drawing or into an open file.

Pasting
To paste a cut or copied object, choose "Paste" from the Edit menu (or 
"Control+V" from the keyboard) and click on the screen where you want 
to paste the object. You can paste multiple copies by repeating this 
procedure.

Deleting
To delete objects, select them then choose "Delete" from the Edit menu, 
or use the "Delete" key on your keyboard.

Duplicating
To duplicate an object once, select it and choose "Duplicate" from the 



Edit menu, or press "Control+D" on the keyboard.  Before you do this, 
however, you should go to the Settings menu and set the parameters for 
duplication by choosing "Duplication Options..." (see below).  These 
parameters will become the default settings.

Selecting All
To select all objects, choose "Select All" from the Edit menu, double click 
anywhere in the drawing, or type "Control+A."  Click anywhere (except 
on the selected object) to deselect all.

View
The View Menu controls certain aspects of SwiftCad's program window: 
the toolbox, status bar and toolbar.  The second set of options displays 
readouts on the toolbar.

Tools
This setting toggles the toolbox on or off.  This can also be done by using
"Control+T" from the keyboard.

Status Bar
The status bar is the small gray bar running along the bottom of the 
window.  It displays cursor location, measurements of objects and cursor 
movement, and a count of selected objects.  It may be toggled on and off
from the menu or by pressing "Control+I."  This choice toggles the status 
bar on and off.  

Toolbar
This  menu selection turns the toolbar at the top of the window on or off.
The toolbar is displayed at the top of the window when this menu 
function is toggled on.  It allows for quick selection of the "New," "Open," 
"Ortho," "Attach," "Zoom Actual," "Zoom All,” “Group," and "Ungroup" 
functions.

Distance
This feature measures the distance that the mouse has traveled in the 
current operation, and displays it in the status bar at the bottom of the 
screen, in the second panel from the left. This distance can be displayed 
in various ways, depending on the "Units" setting described below.

For example, if you want to draw a line 50 units long (whether actual 
length units or scale length units in the drawing), choose "Distance" from 



the View menu. Click on the line icon in the toolbox and begin to draw 
the line. The distance that the mouse has moved is displayed in the 
status bar.

Measuring objects
This feature measures objects you have selected and displays the 
measurement in the units you select in the status bar at the bottom of the
screen.  For lines and arcs, the measurement shown is their length; for 
circles, their circumference; and for rectangles, their perimeter.

For example, to measure a line, choose "Measure" from the Settings 
menu and select the line. The measurement is shown in the status bar, in
the fourth panel from the left. Naturally, if more than one object is 
selected, you will get some odd measurements!

Counting selected objects
To count the selected objects in a drawing, choose "Count" from the 
Settings menu. The number of selected objects appears in the status bar
at the bottom of the screen, in the third panel from the left.

Settings
The Settings Menu controls a number of functions.  It is divided into five 
sections.

The first section of the Settings Menu offers Ortho, Attach, and Relative 
modes that facilitate accurate drafting, and allows you toggle visible page
breaks on and off. 

The second section of the menu allows you to display a grid and have 
lines "snap to" the nearest grid line; to display x- and y-axes originating 
at a specific point; to adjust the units of measurement used in your 
drawing; and to adjust the speed at which you scroll through your 
drawing.

The third section allows you to: set custom background colors;  insert a 
Windows .bmp image as a background; clear the image from your 
drawing.

The fourth section allows you to work with layers--different drawings that 
can be superimposed on each other to form one drawing.

The last section allows you to:  set the color to draw with; select fill 
patterns; change the styles of lines; adjust the precision of measure- 
ments; set the program to draw parallel lines or shapes and adjust how  
far apart they will be; permits you to control duplication of objects.



Ortho mode
To draw or move objects orthogonally, choose "Ortho" from the Settings 
menu.  In orthogonal mode, all lines are drawn either horizontally or 
vertically on 90 degree angles.

Attach mode
In attach mode, the mouse release position is attached to the nearest 
object (i.e. line or arc) end-point. To draw in Attach mode, choose 
"Attach" from the Settings menu. Select the object you want to attach to. 
Draw the line or arc with an end point inside a "handle" of the selected 
object.  This setting is useful for drawing shapes like triangles or 
polygons.

Relative mode
Relative mode allows you to draw objects by specifying their end points 
as offsets, instead of absolute points. To draw in Relative mode, choose 
"Relative" from the Settings menu.

When Relative mode is set, the co-ordinates displayed in the status bar 
at the bottom of the screen indicate the distance from the start point of 
the current operation (usually drawing), and not the absolute co-
ordinates of the cursor on the drawing.

Page breaks
To see where the page breaks occur in your drawing, choose "Page 
breaks" from the Settings menu.

Grid
To mark the screen off with a grid, choose "Grid" from the Settings menu.
Type the dimensions of the x- and y-axes as prompted, and click on 
Show so it is checked. Click on Snap if you want all drawings to snap to 
the grid. To turn the grid off, choose "Grid" again and click on Show to 
uncheck it.

Axes
By choosing this menu item, you can display dashed lines representing 
the x- and y- axes.  You will see a dialogue box which asks you for the 
origin points of the axes and you will be given a check box option to 
show the axes.  Once the axes are set to show, you can move them 
around by clicking on them and dragging them to a new position.



Units
This selection allows you to set the scale of your drawing.  It will produce 
a dialog box which prompts you to set the units on screen in millimeters, 
inches, or pixels and converts them automatically to scale units of  pixels,
millimeters, feet, miles, or kilometers at a ratio that you set. The default is
1 screen unit per 10 "real world" units.
Scrolling Speed
This sets the speed at which the scroll bar will move the viewing window 
around the drawing.

Background Color
Here is where you may set the background color on which you will be 
drawing.  You can even make custom colors.

Background Image
When you select this item, a dialogue box will appear, asking you for the 
name of a Windows .bmp file to import into your drawing.  The drawing 
will only display in sixteen colors.

Clear Background Image
This allows you to remove the background image from the drawing.

Layers
To work with layers, choose "Layers" from the Settings menu. The Layers
dialog box lists the existing layers, and allows you to create, delete, hide,
show, rename and move between layers.

To create a new layer, click on the New button. The new layer, called 
Layer #n by default, appears on the list. Note that a new layer inherits the
current color and line style as a default.

To rename, select the layer name and type the new name in the Rename
box. When you next select a layer, or click on OK, the previously 
selected layer is renamed.

To delete a layer, select it and click on Delete.  Be careful: you cannot 
undo a layer deletion, except with the Cancel button, which cancels all 
operations since you chose the "Layers" option.

To move between layers, select the layer you wish to work on. The title of
the currently selected layer appears in the window title bar. Subsequent 
operations apply only to this layer, until you select another. The 
show/hide button indicates whether the selected layer is hidden or 
showing.



To hide a visible layer, select it and click on Hide, which then becomes 
Show. If you select another visible layer, Show becomes Hide again, and 
you can hide this layer also. The layer you are working on cannot be 
hidden.
Choosing a color
Using the menu:  choose "Color" from the Settings menu. The color 
menu appears to the right of the option.  The current color is marked with
a tick. Change the color of an existing object or objects by selecting them
and then changing the color. You now continue to draw in this color until 
you choose another.

You may also use the toolbox, available from the "View" menu:  open the 
toolbox and click on the required color. You now draw in this color until 
you click on another. The current color is indicated in the toolbox.

Fill Pattern
SwiftCad provides 8 patterns which may be set to fill in objects, solid, 
hatched, hollow squares, diagonal right, cross-hatched, diagonal left, a 
zigzag pattern and a dotted square.

Styles
This feature allows you to set the type of line you will draw: solid, 
dashed, dotted and dotted-dashed. The current style is checked on the 
menu.

Readout Precision
This setting specifies the number of decimal places that will follow any 
measurement:  1, 2, 3 or 4.

Draw Parallel
This menu option permits you to draw parallel lines and shapes.  Note 
that SwiftCad has only one "pencil width."  With this setting you can draw
2 parallel lines that are close together to get the effect of a thick line.  

Parallel options
Clicking on this menu item sets how far apart parallel lines and shapes 
will be drawn.

Duplicate options
Choosing this selection will produce 2 dialogue boxes, the first asks how 
many objects you would like to duplicate, the second prompts you for the
offset.  The first box is the x-coordinate, that is, how far apart should the 
centers of the duplicated objects be drawn, the second box asks for the y



offset, that is how far above or below the selected object should the 
duplicates be drawn.  This setting becomes the default.
Text
The Text Menu contains options for font selection, point size, justification 
and horizontal or vertical positioning of text.

Font
This allows you to choose a line font, provided with SwiftCad, or a 
Windows font.

Horizontal/Vertical
These menu settings allow you to orient your text along the x or y axes.

Left, Center, Right
These settings justify the text, so that it is flush right, centered, or flush 
left.  This all occurs within the "box" in which your text is placed; the box 
can be placed left, right or center in your drawing regardless of the 
setting made from this menu item.

Draw
The Draw Menu allows you to draw objects by specifying absolute or 
relative coordinates from the keyboard. This is particularly useful for 
establishing initial construction lines, for example the outer dimensions of
a measured room. The Draw Menu also allows for dimension lines and 
angles, and functions such as rotate, scale and fillet.  Most of the 
drawing menu commands are also available from the toolbox.

Line
This option prompts you for a beginning and end point specified in x and 
y coordinates, which is useful for precise placement of lines.  Free-
handing with the toolbox is easier, but less precise.

Rectangle
Like the line draw, this selection prompts you to enter the coordinates of 
two sides of the rectangle.  A second dialog box then prompts for the 
second two edges.  If you want to draw a square, you can hold down the 
"Control" key while placing a rectangle.  You may also draw lines in 
multiples of fifteen degrees by holding down the "Control" key while 
drawing a line.

Circle
Selecting this menu item will bring up a dialog box which prompts you for
the center point of the circle in x and y coordinates, then allows you to 
specify the radius.



Arc
This selection will prompt you for the start angle, end angle, exact center 
point in x and y coordinates and the radius of the arc.

Text
This allows the placement of text, selected from the settings menu, in 
your drawing, either horizontally or vertically, as specified in the settings 
menu.  You will be prompted for an insertion point, and then provided 
with a dialogue box in which to enter text.

Dimension Line
This works the same way as the line-draw function, but it inserts a 
measurement of how long the line is, with the units specified from the 
settings menu.  In addition it draws the line with arrowheads at each end.

Dimension Angle
Similar to drawing an arc, this function adds the measurement of the arc 
and arrowheads, as does the Dimension Line function.

Group
This setting allows you to join all selected objects as one selection.

Ungroup
This undoes the "Group" feature, allowing individual selection of objects. 

Lock
This freezes a line, rectangle, or circle into place.

Unlock
This undoes the previous function, returning the selected object to a 
mode where it can be moved easily.

Send to back
Occasionally you'll draw an object on top of another object in a single 
layer.  If you decide that you want the object that is now covered by the 
second object on top, simply select the first object and click on this menu
item.

Send to front
This choice puts a selected object which is behind another object in one 
layer on top.

Rotate



This setting allows you to turn objects through increments of 90 degrees. 
You will be prompted for a center point and for an angle through which to
rotate the object.  The program automatically rounds to the nearest 90 
degrees.  

Scale
This item allows you to move and to resize the selected object.  You will 
be prompted for a center point and for a factor by which to increase the 
size of the object.

Translate
This function allows for the precise movement of objects.  You will be 
prompted for an offset, that is for how far to move the object in the x- and
y- axes.

Mirror
The mirror function allows you to draw a copy of a selected object, 
usually adjacent to it.  When you select the object and choose "Mirror," 
you will be prompted for the x and y coordinates of a starting point and 
an end point.  The selected object is then redrawn in mirror image along 
the line between these points.  This function is also available from the 
toolbox.  With the toolbox, just select the object, click on the mirror tool 
(first button in the fourth row of buttons), draw a line with the cursor, and 
the object will automatically be placed on the other side of the line.

Fillet
Filleting connects two lines by means of an arc of a specified radius.  To 
fillet two lines, select the lines and choose ‘Fillet’ from the Draw menu. 
Enter the radius of the circle which will form the filleting arc as prompted. 
Smartdraw fillets the two lines and crops their ends. This is a good way 
to draw angles, or rounded edges.

If the lines cannot be filleted, for example if they are parallel, a message
appears saying filleting is not possible.  When the endpoints of two lines
are too far apart for them to be filleted using the specified radius, they will
simply be extrapolated or trimmed to their point of intersection by the first
attempt at filleting. Thus a fillet radius of 0 will always cause two lines to
be joined up.  This provides a rudimentary trim facility.

Zoom
The Zoom Menu allows you to magnify or shrink the drawing in various 
ways, for example by zooming to a selection or a specified region.



All
Shows the entire drawing.

Entities
Shows the selected objects.

Region
This allows you to zoom in on a specific region, which you may indicate 
by coordinates.

Previous
This reverts to the last zoom setting, whether it be all, entities, or region.

Windows
The Windows menu allows control of various windows inside the 
SwiftCad window.  It also allows you to arrange the icons of minimized 
windows, close all the drawing windows, and to reorganize open ones.

Cascade
Use this setting to display the layers of your drawing(s) in front of one 
another with their titles visible.  You can also use the "Shift+F5” keys to 
cascade the drawings.

Tile
When this menu item is toggled on, your drawing will display in the whole
window, and will hide the drawings below.  This may be accomplished 
through the keyboard by pressing "Shift+F4."

Arrange Icons
When your drawings are minimized within the SwiftCad window, this 
setting will line them up so that they are easier to see.

Close All
This selection allows you to close all of the drawings in the SwiftCad 
window quickly.  You will be prompted to save any changes.

Current
The last menu item in the "Window" menu allows you to click on the titles
of open drawings to bring them up in the SwiftCad window.

Help



The Help Menu allows you to access on-line help.  (Note that help is 
available on a menu item by pressing the F1 key with the menu item 
selected.)
Keyboard Accelerators
Attach - F6 Open - ^O Cascade - Shift+F5
Ortho - F5 Copy - ^C Paste - ^V
Cut - ^XPrint - ^P Delete - Del
Save - ^S Duplicate - ^D Select All - ^A
GridSnap - F7 Tile - Shift+F Help - F1
Tools - ^T New - ^N Undo - ^Z
"^C" means hold down the control key (Ctrl) while pressing the C key.
"Shift+F5" means hold down the Shift key while pressing the F5 key.
"Del" denotes the Delete key.

Scrolling a drawing using the keyboard
Up/Down/Left/Right: same as click on up/down/left/right scroll
Page Up/Down: scroll up/down one screen
CTRL+Page Up/Down: scroll left/right one screen
Home/End: scroll to left/rightmost point
CTRL+Home/End: scroll to top/bottom
5.  Symbol Libraries
The symbol libraries are standard .DXF files. To select a symbol, use the 
Copy command to copy it to the Clipboard. You can then paste it on the 
current drawing as often as you like.
6.  Trouble Shooting

Insufficient Resources
The system has run out of the resources needed for the operation.  
Close some other applications and/or drawings and try again.

Cannot fillet
The two lines you are attempting to fillet are parallel and an arc between 
them cannot be drawn with the radius specified. Increase the radius.
The layer must be named.  Anonymous layers are not allowed.  Type an 
identifying string into the Rename field.  The active layer may not be 
hidden.  If it were hidden, what would you see?  Select another layer to 
be the active layer, or Show the selected one.

Cannot open Help
Either the on-line help file is missing or system resources are low.
Check that sdw.hlp is in the same directory as the program.  If it is, close 



some other applications and/or drawings and try again.

Cannot decompress file
The drive where temporary files are stored does not have enough free 
space to store the decompressed file.

No shapes found
No drawing entities were recognized in the file. Either they are of a type 
unrecognized by SwiftCad or the file is not a valid Interchange format.

Invalid font file
SwiftCad failed to recognize the specified file as containing a font.  

Invalid numeric field
A number was not found as expected in a dialog box field.  You typed 
"banana" into the grid X field. 

A couple of font tips
Straight Line fonts, such as ISO and Simple, require much less memory 
than smooth arc fonts, so if your drawing is heavily annotated, or if the 
text is required for informative rather than presentation purposes, we 
recommend you use the line fonts.






